Snap! Minimum Specifications

The programming platform used for the Beauty and Joy of Computing curriculum, Snap!, relies on JavaScript that has been standard for over a year. If your system is not up to date, this an cause any number of problems with Snap! (errors when you haven't done anything wrong, sound features not working, etc.)

Please check that your computer browser is at least as up to date as the versions shown below:

BrowserMinimum
Version
Required
Additional Notes
Chrome43Chrome is currently the recommended browser for Snap! *
Safari8.4 
Firefox38 
Edge12However, Microsoft browsers don't support data urls and thus don't allow you to export anything.
Opera32 
IE11Internet Explorer does not comply with web standards. Some features (such as audio) may not work with any version.

For mobile browsers:

DeviceVersion Notes
iPhoneiOS 8 or higher. However on iOS, uploaded sound files can't be played in a script. (All iOS versions have this restriction.)
AndroidUse Chrome for Android and not the stock browser that comes with some devices.

* Please note that sometimes a browser (such as Chrome) may report that it is up to date even though it is far behind the versions shown above. This can happen because of computer access restrictions. In this case, check chrome.google.com every few months.

If you run into errors with Snap! that you believe are not due to an error in your code and your browser does meet these specifications, please clear your browser cache and see if that resolves the problem. If not, please use the blue feedback button in the lower right to let us know exactly what happened; be sure to include your browser and operating system versions in your message.